const regex = /[A-Z]{3}-[0-9]{4}((?:\s[\w-]+)*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]{3}-[0-9]{4}((?:\\s[\\w-]+)*)', 'g')
const str = `|Placa:AVX-4300 Fiat Uno |
|Placa:AVX-4300 Fiat Uno Modelo 2010|
|Placa:AVX-4300 Fiat Uno Modelo 2010 Ano 2011|
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}