#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\d\s@]*(?:\d[^\d\s@]*){0,3}@"
Local $sString = "Imojean.McClements@contaso.com" & @CRLF & _
"Lurette.Mallalieu@contaso.com" & @CRLF & _
"Melodie.Alderton2@contaso.com" & @CRLF & _
"Jillane.Culbard3@contaso.com" & @CRLF & _
"Natalie.Rodliff4@contaso.com" & @CRLF & _
"a1a2b3c@foo.bar" & @CRLF & _
"123@foo.bar" & @CRLF & _
"" & @CRLF & _
"Invalid:" & @CRLF & _
"1234@abc.de" & @CRLF & _
"a1a2b3c4e@abc.de" & @CRLF & _
"76083a888d3b44e08209c9fe4da4ca3dMarcile.Bessant@contaso.com" & @CRLF & _
"af4c06480fce4a829467c62001527cecNatalie.Rodliff2@contaso.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")