const regex = /^[^\d\s@]*(?:\d[^\d\s@]*){0,3}@/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\d\\s@]*(?:\\d[^\\d\\s@]*){0,3}@', 'gm')
const str = `Imojean.McClements@contaso.com
Lurette.Mallalieu@contaso.com
Melodie.Alderton2@contaso.com
Jillane.Culbard3@contaso.com
Natalie.Rodliff4@contaso.com
a1a2b3c@foo.bar
123@foo.bar
Invalid:
1234@abc.de
a1a2b3c4e@abc.de
76083a888d3b44e08209c9fe4da4ca3dMarcile.Bessant@contaso.com
af4c06480fce4a829467c62001527cecNatalie.Rodliff2@contaso.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}