import Foundation
let pattern = #"^[^\d\s@]*(?:\d[^\d\s@]*){0,3}@"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Imojean.McClements@contaso.com
Lurette.Mallalieu@contaso.com
Melodie.Alderton2@contaso.com
Jillane.Culbard3@contaso.com
Natalie.Rodliff4@contaso.com
a1a2b3c@foo.bar
123@foo.bar
Invalid:
1234@abc.de
a1a2b3c4e@abc.de
76083a888d3b44e08209c9fe4da4ca3dMarcile.Bessant@contaso.com
af4c06480fce4a829467c62001527cecNatalie.Rodliff2@contaso.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)