import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\d\\s@]*(?:\\d[^\\d\\s@]*){0,3}@";
final String string = "Imojean.McClements@contaso.com\n"
+ "Lurette.Mallalieu@contaso.com\n"
+ "Melodie.Alderton2@contaso.com\n"
+ "Jillane.Culbard3@contaso.com\n"
+ "Natalie.Rodliff4@contaso.com\n"
+ "a1a2b3c@foo.bar\n"
+ "123@foo.bar\n\n"
+ "Invalid:\n"
+ "1234@abc.de\n"
+ "a1a2b3c4e@abc.de\n"
+ "76083a888d3b44e08209c9fe4da4ca3dMarcile.Bessant@contaso.com\n"
+ "af4c06480fce4a829467c62001527cecNatalie.Rodliff2@contaso.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}