# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\d\s@]*(?:\d[^\d\s@]*){0,3}@"
test_str = ("Imojean.McClements@contaso.com\n"
"Lurette.Mallalieu@contaso.com\n"
"Melodie.Alderton2@contaso.com\n"
"Jillane.Culbard3@contaso.com\n"
"Natalie.Rodliff4@contaso.com\n"
"a1a2b3c@foo.bar\n"
"123@foo.bar\n\n"
"Invalid:\n"
"1234@abc.de\n"
"a1a2b3c4e@abc.de\n"
"76083a888d3b44e08209c9fe4da4ca3dMarcile.Bessant@contaso.com\n"
"af4c06480fce4a829467c62001527cecNatalie.Rodliff2@contaso.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.