re = /^[^\d\s@]*(?:\d[^\d\s@]*){0,3}@/m
str = 'Imojean.McClements@contaso.com
Lurette.Mallalieu@contaso.com
Melodie.Alderton2@contaso.com
Jillane.Culbard3@contaso.com
Natalie.Rodliff4@contaso.com
a1a2b3c@foo.bar
123@foo.bar
Invalid:
1234@abc.de
a1a2b3c4e@abc.de
76083a888d3b44e08209c9fe4da4ca3dMarcile.Bessant@contaso.com
af4c06480fce4a829467c62001527cecNatalie.Rodliff2@contaso.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end