use strict;
my $str = 'Imojean.McClements@contaso.com
Lurette.Mallalieu@contaso.com
Melodie.Alderton2@contaso.com
Jillane.Culbard3@contaso.com
Natalie.Rodliff4@contaso.com
a1a2b3c@foo.bar
123@foo.bar
Invalid:
1234@abc.de
a1a2b3c4e@abc.de
76083a888d3b44e08209c9fe4da4ca3dMarcile.Bessant@contaso.com
af4c06480fce4a829467c62001527cecNatalie.Rodliff2@contaso.com';
my $regex = qr/^[^\d\s@]*(?:\d[^\d\s@]*){0,3}@/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}