# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+?)((?:\s\w+\.){0,}\[{0,}(`){0,}Тип заканчивания\3{0,}\]{0,})(.+)$/$1$2$4 GROUP BY $2/gs;t' <<< "SELECT `Тип заканчивания`,
`Дата ввода` FROM [DeleteMe8$A1:B21]
"