const regex = /^(.+?)((?:\s\w+\.){0,}\[{0,}(`){0,}Тип заканчивания\3{0,}\]{0,})(.+)$/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+?)((?:\\s\\w+\\.){0,}\\[{0,}(`){0,}Тип заканчивания\\3{0,}\\]{0,})(.+)$', 'gs')
const str = `SELECT \`Тип заканчивания\`,
\`Дата ввода\` FROM [DeleteMe8\$A1:B21]
`;
const subst = `$1$2$4 GROUP BY $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);