import re
regex = re.compile(r"^(.+?)((?:\s\w+\.){0,}\[{0,}(`){0,}Тип заканчивания\3{0,}\]{0,})(.+)$", flags=re.DOTALL)
test_str = ("SELECT `Тип заканчивания`, \n"
"`Дата ввода` FROM [DeleteMe8$A1:B21]\n")
subst = "$1$2$4 GROUP BY $2"
result = regex.sub(subst, test_str)
if result:
print(result)