#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)^(.+?)((?:\s\w+\.){0,}\[{0,}(`){0,}Тип заканчивания\3{0,}\]{0,})(.+)$"
Local $sString = "SELECT `Тип заканчивания`, " & @CRLF & _
"`Дата ввода` FROM [DeleteMe8$A1:B21]" & @CRLF & _
""
Local $sSubst = "$1$2$4 GROUP BY $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)