#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) (?:" & @CRLF & _
" (?! in [ ] \d{4} )" & @CRLF & _
" [A-Za-z ] " & @CRLF & _
" )+" & @CRLF & _
" (" & @CRLF & _
" in [ ] " & @CRLF & _
" (?P<year> \d\d\d\d )" & @CRLF & _
" )?" & @CRLF & _
" \s? " & @CRLF & _
" (" & @CRLF & _
" in [ ] " & @CRLF & _
" (?P<country> [A-z]+ )" & @CRLF & _
" )?" & @CRLF & _
""
Local $sString = "I am born in 2000 in hungary"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")