re = / (?:
(?! in [ ] \d{4} )
[A-Za-z ]
)+
(
in [ ]
(?P<year> \d\d\d\d )
)?
\s?
(
in [ ]
(?P<country> [A-z]+ )
)?
/x
str = 'I am born in 2000 in hungary'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end