const regex = new RegExp(' (?:
(?! in [ ] \\d{4} )
[A-Za-z ]
)+
(
in [ ]
(?P<year> \\d\\d\\d\\d )
)?
\\s?
(
in [ ]
(?P<country> [A-z]+ )
)?
', 'g')
const str = `I am born in 2000 in hungary`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}