import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (?:\n"
+ " (?! in [ ] \\d{4} )\n"
+ " [A-Za-z ] \n"
+ " )+\n"
+ " (\n"
+ " in [ ] \n"
+ " (?P<year> \\d\\d\\d\\d )\n"
+ " )?\n"
+ " \\s? \n"
+ " (\n"
+ " in [ ] \n"
+ " (?P<country> [A-z]+ )\n"
+ " )?\n";
final String string = "I am born in 2000 in hungary";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}