$re = '/ (?:
(?! in [ ] \d{4} )
[A-Za-z ]
)+
(
in [ ]
(?P<year> \d\d\d\d )
)?
\s?
(
in [ ]
(?P<country> [A-z]+ )
)?
/x';
$str = 'I am born in 2000 in hungary';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);