// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x) (?:
(?! in [ ] \d{4} )
[A-Za-z ]
)+
(
in [ ]
(?P<year> \d\d\d\d )
)?
\s?
(
in [ ]
(?P<country> [A-z]+ )
)?
").unwrap();
let string = "I am born in 2000 in hungary";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}