import re
regex = re.compile(r"""
(?:
(?! in [ ] \d{4} )
[A-Za-z ]
)+
(
in [ ]
(?P<year> \d\d\d\d )
)?
\s?
(
in [ ]
(?P<country> [A-z]+ )
)?
""", flags=re.VERBOSE)
test_str = "I am born in 2000 in hungary"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")