using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)";
string substitution = @"\11";
string input = @"hello 55 friends
i am 29 happ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}