// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+)").unwrap();
let string = "hello 55 friends
i am 29 happ";
let substitution = "\\11";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}