use strict;
my $str = 'hello 55 friends
i am 29 happ';
my $regex = qr/(\d+)/p;
my $subst = '\\11';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";