import Foundation
let pattern = #"(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
hello 55 friends
i am 29 happ
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\11"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)