const regex = /(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)', 'g')
const str = `hello 55 friends
i am 29 happ`;
const subst = `\11`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);