#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[A-Z])(?!.*_).+"
Local $sString = "FALSE:" & @CRLF & _
"example-chocolate-easter-egg-170g_349-85428671-ACCESSIBLEEASTEREGG" & @CRLF & _
"chocolate-easter-egg-170g349-85428671-accessibleeasteregg" & @CRLF & _
"" & @CRLF & _
"TRUE:" & @CRLF & _
"example-chocolate-easter-egg-170g349-85428671-ACCESSIBLEEASTEREGG" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")