import re
regex = re.compile(r"^(?=.*[A-Z])(?!.*_).+", flags=re.MULTILINE)
test_str = ("FALSE:\n"
"example-chocolate-easter-egg-170g_349-85428671-ACCESSIBLEEASTEREGG\n"
"chocolate-easter-egg-170g349-85428671-accessibleeasteregg\n\n"
"TRUE:\n"
"example-chocolate-easter-egg-170g349-85428671-ACCESSIBLEEASTEREGG\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")