$re = '/^(?=.*[A-Z])(?!.*_).+/m';
$str = 'FALSE:
example-chocolate-easter-egg-170g_349-85428671-ACCESSIBLEEASTEREGG
chocolate-easter-egg-170g349-85428671-accessibleeasteregg
TRUE:
example-chocolate-easter-egg-170g349-85428671-ACCESSIBLEEASTEREGG
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);