import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[A-Z])(?!.*_).+";
final String string = "FALSE:\n"
+ "example-chocolate-easter-egg-170g_349-85428671-ACCESSIBLEEASTEREGG\n"
+ "chocolate-easter-egg-170g349-85428671-accessibleeasteregg\n\n"
+ "TRUE:\n"
+ "example-chocolate-easter-egg-170g349-85428671-ACCESSIBLEEASTEREGG\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}