# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)\\/(infografik\-kategorien)\\/(.*)\\/(?!.term)(.*)/https:\/\/test.ixtract.de\/infografik-kategorien\/$3\/?term=$3/gm;t' <<< "https://test.ixtract.de/infografik-kategorien/prozess/"