$re = '/(.*)\/(infografik\-kategorien)\/(.*)\/(?!.term)(.*)/m';
$str = 'https://test.ixtract.de/infografik-kategorien/prozess/';
$subst = "https://test.ixtract.de/infografik-kategorien/$3/?term=$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;