import re
regex = re.compile(r"(.*)\/(infografik\-kategorien)\/(.*)\/(?!.term)(.*)", flags=re.MULTILINE)
test_str = "https://test.ixtract.de/infografik-kategorien/prozess/"
subst = "https://test.ixtract.de/infografik-kategorien/$3/?term=$3"
result = regex.sub(subst, test_str)
if result:
print(result)