import Foundation
let pattern = #"(.*)\/(infografik\-kategorien)\/(.*)\/(?!.term)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://test.ixtract.de/infografik-kategorien/prozess/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https://test.ixtract.de/infografik-kategorien/$3/?term=$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)