import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)\\/(infografik\\-kategorien)\\/(.*)\\/(?!.term)(.*)";
final String string = "https://test.ixtract.de/infografik-kategorien/prozess/";
final String subst = "https://test.ixtract.de/infografik-kategorien/$3/?term=$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}