use strict;
my $str = 'https://test.ixtract.de/infografik-kategorien/prozess/';
my $regex = qr/(.*)\/(infografik\-kategorien)\/(.*)\/(?!.term)(.*)/mp;
my $subst = 'https://test.ixtract.de/infografik-kategorien/$3/?term=$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";