using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)\/(infografik\-kategorien)\/(.*)\/(?!.term)(.*)";
string substitution = @"https://test.ixtract.de/infografik-kategorien/$3/?term=$3";
string input = @"https://test.ixtract.de/infografik-kategorien/prozess/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}