package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+\(\d+(?:\.\d+)?%\)`)
var str = `orange (43%), blue (2.1) (55%), red yellow (77%), red-blue (80%)
orange, blue (2.1), red yellow, red-blue`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}