$re = '~\s+\(\d+(?:\.\d+)?%\)~m';
$str = 'orange (43%), blue (2.1) (55%), red yellow (77%), red-blue (80%)
orange, blue (2.1), red yellow, red-blue';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;