re = /\s+\(\d+(?:\.\d+)?%\)/m
str = 'orange (43%), blue (2.1) (55%), red yellow (77%), red-blue (80%)
orange, blue (2.1), red yellow, red-blue'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result