const regex = new RegExp('\\s+\\(\\d+(?:\\.\\d+)?%\\)', 'gm')
const str = `orange (43%), blue (2.1) (55%), red yellow (77%), red-blue (80%)
orange, blue (2.1), red yellow, red-blue`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);