import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+\\(\\d+(?:\\.\\d+)?%\\)";
final String string = "orange (43%), blue (2.1) (55%), red yellow (77%), red-blue (80%)\n"
+ "orange, blue (2.1), red yellow, red-blue";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}