package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(Deathtouch|(Double|First)\sStrike|Flying|Hexproof|(Indestructib|Tramp)le|(Men|Vigil)an?ce|Lifelink|Reach)\sCounter`)
var str = `Deathtouch Counter
Double Strike Counter
First Strike Counter
Flying Counter
Hexproof Counter
Trample Counter
Reach Counter
Menace Counter
Lifelink Counter
Indestructible Counter
Vigilance Counter
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}