// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(Deathtouch|(Double|First)\sStrike|Flying|Hexproof|(Indestructib|Tramp)le|(Men|Vigil)an?ce|Lifelink|Reach)\sCounter").unwrap();
let string = "Deathtouch Counter
Double Strike Counter
First Strike Counter
Flying Counter
Hexproof Counter
Trample Counter
Reach Counter
Menace Counter
Lifelink Counter
Indestructible Counter
Vigilance Counter
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}