import Foundation
let pattern = #"(Deathtouch|(Double|First)\sStrike|Flying|Hexproof|(Indestructib|Tramp)le|(Men|Vigil)an?ce|Lifelink|Reach)\sCounter"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Deathtouch Counter
Double Strike Counter
First Strike Counter
Flying Counter
Hexproof Counter
Trample Counter
Reach Counter
Menace Counter
Lifelink Counter
Indestructible Counter
Vigilance Counter
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)