import re
regex = re.compile(r"(Deathtouch|(Double|First)\sStrike|Flying|Hexproof|(Indestructib|Tramp)le|(Men|Vigil)an?ce|Lifelink|Reach)\sCounter", flags=re.IGNORECASE)
test_str = ("Deathtouch Counter\n"
"Double Strike Counter\n"
"First Strike Counter\n"
"Flying Counter\n"
"Hexproof Counter\n"
"Trample Counter\n"
"Reach Counter\n"
"Menace Counter\n"
"Lifelink Counter\n"
"Indestructible Counter\n"
"Vigilance Counter\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")