re = /(Deathtouch|(Double|First)\sStrike|Flying|Hexproof|(Indestructib|Tramp)le|(Men|Vigil)an?ce|Lifelink|Reach)\sCounter/i
str = 'Deathtouch Counter
Double Strike Counter
First Strike Counter
Flying Counter
Hexproof Counter
Trample Counter
Reach Counter
Menace Counter
Lifelink Counter
Indestructible Counter
Vigilance Counter
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end