use strict;
my $str = 'Deathtouch Counter
Double Strike Counter
First Strike Counter
Flying Counter
Hexproof Counter
Trample Counter
Reach Counter
Menace Counter
Lifelink Counter
Indestructible Counter
Vigilance Counter
';
my $regex = qr/(Deathtouch|(Double|First)\sStrike|Flying|Hexproof|(Indestructib|Tramp)le|(Men|Vigil)an?ce|Lifelink|Reach)\sCounter/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}