# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?[\\\\/]src[\\\\/]|([\\\\/])/\\/g;t' <<< "/home/me/projects/project/src/Commands/Interfaces/Whatever
"