$re = '/^.*?[\\\\\/]src[\\\\\/]|([\\\\\/])/';
$str = '/home/me/projects/project/src/Commands/Interfaces/Whatever
';
$subst = "\\";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;