use strict;
my $str = '/home/me/projects/project/src/Commands/Interfaces/Whatever
';
my $regex = qr/^.*?[\\\/]src[\\\/]|([\\\/])/p;
my $subst = '\\\\';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";