#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^.*?[\\\/]src[\\\/]|([\\\/])"
Local $sString = "/home/me/projects/project/src/Commands/Interfaces/Whatever" & @CRLF & _
""
Local $sSubst = "\\"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)